Subaru XV Crosstrek Forums banner

1 - 3 of 3 Posts

·
Registered
2017 XV Limited. Replaced wimpy lighting with Diode Dynamics inside & out. E-trailer 2” hitch.
Joined
·
2 Posts
Discussion Starter #1
Happy to be joining this Forum. Sorry to say a problem nudged me. We have a ‘17 Limited w/ Eye Sight, purchased August ‘18 as a CPO with 6K miles. The only modification was right away to replace the wimpy OEM lighting with Diode Dynamics LEDs inside & out; maybe this becomes relevant later on...

In early ‘19 the TPMS began showing an intermittent error - flashing for a minute and then shining steady, sometimes staying on, sometimes going out. This happened on maybe every 10th outing, and usually after about 10 minutes on the road, sometimes highway, sometimes city.

The first time to the dealer said it was tire pressure sensitivity. (This is a Gen. 1 so no individual tire readings.) I closely monitored the cold pressures with a good gauge and still had intermittent errors. Five months later they replaced the TPMS module. Shortly after that my wife reported the warning light’s return; we blew it off only to find she’d picked up a screw and a tire was indeed losing pressure.

A couple of months after that, and still with TPMS gremlins, it’s back to the dealer. Another replacement TPMS module and this time, on the way home from the dealer, the flashing light came back. We turned around to the dealer, where the car’s been since Friday. The “good” news is that they’ve been able to get the error signal to come on this time. They say they’re now in the wiring harness trying to track “something“ down.

As part of full disclosure, I’ve told them each time about the aftermarket LEDs. But the service writer said he’s done the same thing to his Subie and has no such issues, and Diode Dynamics insists their equipment couldn’t be the culprit.

I’ve seen a number of posts on this Forum about the TPMS, mostly related to the individual tire sender units and resets after new tires. But, a check on the neighboring Ascent Forum just revealed a few owners with issues that sound a lot like this.

As both a question and a public service announcement, does this ring a bell for any of you?
 

·
Registered
2017 XV Limited. Replaced wimpy lighting with Diode Dynamics inside & out. E-trailer 2” hitch.
Joined
·
2 Posts
Discussion Starter #2
An update: The dealer reported a few loose pins in a connector, and replaced the TPMS module. So, including the one they installed the previous week, this is module #4. Stay tuned.
 

·
Registered
Joined
·
1,261 Posts
I also use LEDs without problems.
 
1 - 3 of 3 Posts
Top