Subaru Crosstrek and XV Forums banner

1 - 3 of 3 Posts

·
Registered
XV CROSSTREK Hybrid 2014
Joined
·
1 Posts
Discussion Starter #1
Hello, members, I have a problem in my hybrid Crosstrek 2014 with 60K miles. The Electric mode doesn't work correctly ( the engine is always on at low speed, and the EV indicator is off). I need your help because the dealership pulled out of the market. and the mechanics can't be decided on the problem. So I did not reach a conclusion and the problem still exists.
1) rest the car by removing the supporting battery cable for 10 minutes
2) I checked the hybrid battery cutter (orange cutter) at the rear of the car
3) I checked the car using a modern computer and was unable to access the hybrid system and did not detect any other problems
 

Attachments

·
Registered
2019 Crosstrek PHEV Lagoon Blue Pearl
Joined
·
111 Posts
Have you ever driven the car in pure EV mode?

If not:

1) You can't press down on the throttle very far, basically only works in parking lots or slow trails.
2) Your location means it is hot, a lot. If the car needs to use A/C it will use the engine. Make sure the interior temperature and exterior aren't very different, even humidity.

If yes:

Not sure, sorry. E-mail Subaru global.
 

·
Registered
Joined
·
4 Posts
Hello, members, I have a problem in my hybrid Crosstrek 2014 with 60K miles. The Electric mode doesn't work correctly ( the engine is always on at low speed, and the EV indicator is off). I need your help because the dealership pulled out of the market. and the mechanics can't be decided on the problem. So I did not reach a conclusion and the problem still exists.
1) rest the car by removing the supporting battery cable for 10 minutes
2) I checked the hybrid battery cutter (orange cutter) at the rear of the car
3) I checked the car using a modern computer and was unable to access the hybrid system and did not detect any other problems
Subaru XV Hybrid has 3 batteries fitted in the car. The hybrid battery is in the boot of the car, the Start/Stop battery is in front of the drivers seat and third battery is in front of the passenger seat next to drivers seat.

Check the Start/Stop battery and the other battery apart from the Hybrid battery. The EV mode on my Subaru XV Hybrid 2015 (Japanese) model had stopped working for more than 2 months and 3 days ago, two lights which indicate "Hybrid system fail" and "EyeSight" starting showing on my dashboard. I got the 2 batteries under the bonnet checked where the Start/Stop battery had failed and the other battery was showing a weak status so I replaced them both at a total cost of $465.00. Within 5minutes of replacing these batteries, the EV mode starting working and even better than when first bought it (imported from Japan 1 and a half years ago). I asked around out 3 different places for checking out the battery status and the replacement cost and one thing all battery specialists advised was to replace both the batteries under the bonnet at the same time and not just one.

Try this before trying anything else as the Start/Stop battery in this model is apparently notoriously bad after about 4 years of use.
 
1 - 3 of 3 Posts
Top