Subaru XV Crosstrek Forums banner

21 - 24 of 24 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #21
So I went to the dealer and got my recall done. I asked them to update my firmware and they did but it NOT fix Apple car play. But they were not fazed by me having a different screen in my '18 Crosstrek Premium. So I'll go again when I have some more free time and tell them my USB port doesn't work. I read that some people got it fixed no problem (and they didn't do a screen swap they just had the issue). Another user on the Impreza Forum linked me to this PDF (attached) and gave some insight.

So the next thing I'll do is ask them about the USB and I'll update from there.
 

Attachments

·
Registered
Joined
·
28 Posts
So I went to the dealer and got my recall done. I asked them to update my firmware and they did but it NOT fix Apple car play. But they were not fazed by me having a different screen in my '18 Crosstrek Premium. So I'll go again when I have some more free time and tell them my USB port doesn't work. I read that some people got it fixed no problem (and they didn't do a screen swap they just had the issue). Another user on the Impreza Forum linked me to this PDF (attached) and gave some insight.

So the next thing I'll do is ask them about the USB and I'll update from there.
Good info. I was curious what sort of reaction I'd get when I inevitably bring it in for service since I'll be under warranty pretty much the entire time I have the car.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #23
Alright, so it's been some time since I made an update. I recently went to my dealer to get my USB/Apple Carplay fixed. They told me they needed to get a new USB Port, and it's gonna take some time to get it in stock. The next time I come in they said the USB was still not working and told me they needed to order a new wiring harness (they were not clear on what it was). This was all done under warranty so no payment at all.

The original problems were the power and data were intermittent, it would disconnect and connect every 2 seconds. So no charging or data pass-through. That meant no Apple Carplay, after they installed everything, Apple Carplay still DOES NOT work. My phone doesn't even detect a car, pre-fix it would detect my car but like I said the connection was intermittent so after 2 secs it wasn't stable enough for carplay. Post fix, I can plug in my phone and use Subaru's own Media interface to stream music and charge my phone. It's kinda annoying that the dealer didn't connect an iphone to test it. I tested with 3 different iPhones (5s, 6s and Xs) with 3 different iOS versions. None of them worked. Tried different cables, nope. I plan on going tomorrow again and I'll update soon.
 
21 - 24 of 24 Posts
Top