Subaru XV Crosstrek Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi all,

sorry to ask this, may be there is something in other threads but I wasn't able to found the same issue.
There are many documents about the cliccking noise due to the CV axles broken , but my MY15 Crosstreck seems have another problem.
The Click noise raise clearly from the suspension / drivetrain , and almost at the end of the steering rotation when I'm parking the car p..e
Coming from the left if I'm turning on left , and the same from the other side
It's a sort of TAC! like a little hammer on a hard surface, not a crack noise.
Nothing if I'm driving slow in a small circle, in both directions.
Brakes are news, rotors and pads , changed yesterday. nothing happened as I imagined.
I'm not confident the dealer near me can fix this problem, this due my experience about my MY19 BRZ , at first service was a complete disaster.
May someone help me please?
txs in advance, and have a great we
 

·
Registered
Joined
·
7 Posts
My best guess is the brake pads are new so they stick a bit. once they wear in just a bit, see if that sound continues. I get something similar whenever I wash my car and the brakes get cleaned up. just my guess though.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Hi, thanks for your answer.
I know the sound you mention it’s happens when the car start to move after stopping with new/wet brake pads and they are lightly glued on rotors surface.
The issue I’m experiencing is a noise when I’m turning the steering. the car is parked.push the brake.almost at the end of the last round.only one toc.
the car is total stock.
I’m looking at the springs ar the upper side of the schocks because no noise is make when I’m driving normally with small angles of steering.
anyway ,this is drive me crazy.
have a nice day
 

·
Registered
Joined
·
22 Posts
I had a car that had a loud clicking sound coming from the passenger side. It only happened when I went over a speed bump or a pot hole. By pushing up and down on that fender you could hear that noise was coming from the strut tower.Still under warranty,Dealer couldn't figure it out but i did. It was a broken spot weld in the strut tower. They fixed it by removing the strut and drilled out the spot weld, Then used sheet metal screws to draw the metal tight either side of bad weld.Then welded the spot weld hole , then removed the sheet metal screws and welded thoses hole as well . This is probably not your problem, but the dealer said this was their first one they ever seen with this problem . Unfortunately you may be the first and only person with this problem. Good Luck.
 
1 - 5 of 5 Posts
Top