Subaru Crosstrek and XV Forums banner
201 - 216 of 216 Posts

·
Registered
Joined
·
61 Posts
That's great to hear for you. If you have a part number for your unit, let me know. I watched the install process and frankly something on the passengers side sounds easier. Did you have to take off the manifold too like they did in this video?
Yeah the part number is CRF-S0696 on OAKOS
It shows the picture of the older version but it’s the one that mounts on the side.

I did take off the intake and all that but you don’t really have to. Just makes it easier to install with the limited space in there.
I do notice a difference in my engine. It doesn’t pulsate when the ac is on. Like draw from the engine. It idles really smooth and idk if horsepower increased or anything.. but no smoke yet.
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #203 ·
Yeah the part number is CRF-S0696 on OAKOS
It shows the picture of the older version but it’s the one that mounts on the side.

I did take off the intake and all that but you don’t really have to. Just makes it easier to install with the limited space in there.
I do notice a difference in my engine. It doesn’t pulsate when the ac is on. Like draw from the engine. It idles really smooth and idk if horsepower increased or anything.. but no smoke yet.

I decided to copy you and ordered one for me last night. The install process looks pretty easy.
Will report back but sounds like I might have a little lag before I have it in hand.
 

·
Registered
Joined
·
61 Posts
I decided to copy you and ordered one for me last night. The install process looks pretty easy.
Will report back but sounds like I might have a little lag before I have it in hand.
Nice! I’ve had it on for about a week and notice a difference. It did take them a bit to ship it when I got mine. Hopefully doesn’t take them too long..

The install process is straight forward, it’s just a matter of getting those rubber hoses through and connected. They are thick and it’s a tight fit. There is like this insulation foam you have to go over so it’s not touching anything hot and then under the EGR tube which is silver and then connect it to the PCV valve. The intake end is easier.
I just really hope this AOS helps our issue. Supposed to help with oil consumption due to the boxer engine design.. I know a lot of STI owners use like catch cans or AOS because of the blow by..
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #205 ·
Nice! I’ve had it on for about a week and notice a difference. It did take them a bit to ship it when I got mine. Hopefully doesn’t take them too long..

The install process is straight forward, it’s just a matter of getting those rubber hoses through and connected. They are thick and it’s a tight fit. There is like this insulation foam you have to go over so it’s not touching anything hot and then under the EGR tube which is silver and then connect it to the PCV valve. The intake end is easier.
I just really hope this AOS helps our issue. Supposed to help with oil consumption due to the boxer engine design.. I know a lot of STI owners use like catch cans or AOS because of the blow by..



Yeah, that is my understanding too. I really hope as well. Would love to increase the life of this car at least in the near term. I also finally got my matte black hood decal which looks sweet. Pretty cool. Will have to post up a few pics.
 

·
Registered
Joined
·
61 Posts
Yeah, that is my understanding too. I really hope as well. Would love to increase the life of this car at least in the near term. I also finally got my matte black hood decal which looks sweet. Pretty cool. Will have to post up a few pics.
Well OAKOS emailed me and told me Crawford is out of stock :(
Waiting for Crawford to give me an ETA if at all possible.
Ahh.. Well hopefully it doesn’t take too long to get some more in..
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #209 ·
So I got a puff of smoke on startup today.. so idk if the AOS will help with that issue.. I think it’s just a mystery.. 🤷🏽‍♂️

Ah man, well that's a total drag. I haven't seen it lately on my end. I've been intentionally parking it level or the nose up or driver side down intentionally so the smoke stays away.
I feel like there is something happening that didn't when the car was new, but tearing into it is too costly for an issue that isn't causing massive consumption.
 

·
Registered
Joined
·
61 Posts
Ah man, well that's a total drag. I haven't seen it lately on my end. I've been intentionally parking it level or the nose up or driver side down intentionally so the smoke stays away.
I feel like there is something happening that didn't when the car was new, but tearing into it is too costly for an issue that isn't causing massive consumption.
I’ve been parking it on a slope just to test it.. it has smoked a few times. I think I’m just gonna park it on level surface now.. I really think the slope is an issue.. I have parked the opposite way with engine up and it doesn’t smoke..

Same. When I first bought it I drove it long distance no problem then started noticing smoke.. we have about the same amount of miles. Car runs good though. Good gas mileage. Sounds good and healthy. But just a cough of smoke. Maybe it’s just a Subaru thing lol..
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #211 ·
Yeah I'm in the exact same boat. I wouldn't go so far to say it's normal but I'm now seeing and finding more and more people have the issue. I'm just gonna wait to see if it gets worse and then gonna bring it back to Subaru with a big bag of "I told you guys"

Frustrating, but the car other than that runs like a top. I'm also in agreement with you after the fuel system service the engine seems quieter. Less violent at higher revs.
 

·
Registered
Joined
·
5 Posts
im also experiencing this its super random, happens a couple starts in a row then not for a month but it has continued, also no oil loss or running strange not sure what to make of it im right at 65k miles now 2018 premium
 

·
Registered
Joined
·
61 Posts
im also experiencing this its super random, happens a couple starts in a row then not for a month but it has continued, also no oil loss or running strange not sure what to make of it im right at 65k miles now 2018 premium
Yeah that sounds about right. We both have the same amount of miles and same issues. We have tried it all.. if you read through the thread…
At this point I’m not really worried about it.. not a significant amount of oil loss at all and car runs smooth. Just a Subaru thing I guess..
 

·
Registered
Joined
·
2 Posts
Sincerely thank you guys very much for listing and being thorough here. 2018 Crosstrek Premium with 113,500mi. Drive it for work in some of the sh! Tiest stop and go rush hours in our nation. Also drive it an average of 70-85mph hwy. Vacations are off road camping 4-10 hours away or snowboarding 10 hours away.

So I've put some time into this car and still absolutely love it. Did the Diff fluid at 90k do my own 0w-20 changes with a fumoto valve for draining (GET the crush washer from the dealer and have a spare plug in case). Just got spark plugs and air induction done that I added after a bearring went out under warranty. I've noticed the smoke, definitely smells like rich oil/gas mix and only at start up from time to time. Weeks or months in between. Did the PCV myself due to milage and sure as hell smoked again. I've spent 3 days on this blog and again. Thank you for the info! Keep up with regular maintenance and hopefully we'll get as much out of it as The Wolverine. Guy hot a 2015 (or 13) and put 100k mi on it the first year. Got 650k mi out of the motor and a PCV every 100-200. Even spread his oil changes out to 12k mi due to his 'regular commute'..
 

·
Registered
Joined
·
2 Posts
I added a link to the part of Wolverine's chain where I recap from 2015-21 the repair intervals he had on his manual. Keep in mind we have CVTs and timing chains. Also the CVT is chain driven for our year.


I wanted to see what preventative maintenance I needed since I noticed I had nearly double the milage on my 2018 even back in 2021. This guy really made me feel comfortable with my purchase.

Been reading on here and that forum site since I got mine. If it's not answered on this one, it probably is on that one.
 
201 - 216 of 216 Posts
Top