Subaru XV Crosstrek Forums banner

1 - 20 of 999 Posts

·
Super Moderator
Joined
·
3,563 Posts
Discussion Starter #2
I mostly like the HU in the new XV, and I love Apple Play.
But I cannot stand/detest/hate that you cannot permanently turn off the audio!
As soon as you turn on the car, the radio starts blaring. If the last thing you used was Bluetooth, then that starts blaring. The only way around that is to remember to turn the sound down to zero before you turn off the car.
Also, when you're using Apple Play and you've turned off whatever you've been listening to by touching the screen...as soon as you turn off the car, the radio starts blaring again!
Also, the audio does not stop when you turn off the car...you physically have to open the door for it to stop, or reach over and turn off the button.
This HU is different from the previous models, which used to remember when you turned off the audio...so when you restart the car, the audio was already off. This one, with the audio permanently on, is driving me crazy!
 

·
Registered
Joined
·
188 Posts
I dislike it when a passenger iPhone is plugger into charge at the front USBs (the easy access ones) and the HU disconnected Bluetooth from my phone that was playing music and demands apple car play and refuses anything else.

I dislike the way it vocalises "towards" when gpsing.

Idislike that the GPS map autozoom is very needy. I can't have autozoom enabled in menu and during driving adjust a particular scale and make it stay there. After a few seconds it reverts to Auto.

The touchscreen may become unresponsive if you do things too quick. Like typing too quick or dragging the map around too quick.
 

·
Registered
Joined
·
60 Posts
The night I purchased mine, I had an issue with the BT connection between my phone and the HU. I had it in the accessory position, connected my phone and began music. Upon starting it up, the HU said the phone was still connected, but the phone did not show any connections. Couldn't "disconnect" the phone on the HU, delete it, anything. Couldn't reconnect the phone. Ended up doing a factory data reset on the HU, hasn't happened since.

I've also noticed that when I have any audio playing via BT, there is a constant ticking noise. It doesn't happen in my girlfriend's Honda, or with my BT headphones, and it does not matter what the audio input is (music on the phone, pandora, etc.).
 

·
Registered
Joined
·
60 Posts
i had an issue with Android Auto disconnecting for no reason, but the issue wasn't the headunit or my phone. Turns out it was a cheap USB cable that i bought. Swapped it with a better one and it works great not.
Wait, so it wasn't the cable then? The 'not' at the end has me confused...
 

·
Registered
2017 Crosstrek Limited
Joined
·
1,203 Posts
Sure it is a typo and the OP meant "and it works great now."
 

·
Registered
Joined
·
34 Posts
HU has been ok so far ( 13 days ) re freezing/weird things but does become slow to respond when you select things at a "normal" speed.

Annoyances ....

Media-USB artist/album selection insisting on sorting Alphabetically on MP3 tags even though I've named the files 01_1st track.mp3, 02_2ndtrack.mp3 etc.
This can be solved by putting a playlist in each album folder and just selecting playlists ( you do then lose the artist/album selection )

DEbsXV issue with the radio insisting on being turning on when you stop , or start, the car. If it was on USB at vol3, I want it to start up there, or stay at least quiet until I decide otherwise. Don't select radio at X volume automatically.

It would be nice if you could turn Navigation audio prompts off and just use prompts on the screen/info display. Even turning the Nav volume to zero still interrupts the music when it wants to say something. I know roughly where I'm going, just prompt me on the screen when the turn is coming up.

Otherwise a very nice car :)
 

·
Registered
Joined
·
188 Posts
It would be nice if you could turn Navigation audio prompts off and just use prompts on the screen/info display. Even turning the Nav volume to zero still interrupts the music when it wants to say something. I know roughly where I'm going, just prompt me on the screen when the turn is coming up.

Otherwise a very nice car :)
You can turn off nav audio prompts. Tap the nav screen, on the right there are three buttons placed vertically. The centre one, an image of a speaker, is mute if you press it.

I love being able to mute it.
 

·
Registered
Joined
·
29 Posts
DebsXV - i have to declare that i absolutely LOVE the fact the music keeps playing when you've turned off the car, but are yet to get out... Feel like that's finesse and is hopefully built by design as have found it to be very convenient.

On the contrary yes, the volume factor and not being able to turn it off by choice - so even though a workaround is to set it to zero volume when you stop the car, if you were playing Pandora (back when it existed in AUS), and got back in the car - you then come to realise it's back to playing via the phone in your pocket as soon as you start the car.
#Facepalm

Can't think of any other pain points at this stage now that i've gotten used to where everything is - thanks to guidance above, for instance, how to stop the GPS voice and its vocal guidance 'TOWADS' the destination.
 

·
Registered
Joined
·
1,078 Posts
Weird little bug...if I plug in my phone before I start the car, it goes into a loop where it's trying to connect to a bluetooth device, fails, and tries to connect again. Android Auto won't function properly as a result. If I turn the car on and then plug in my phone, no issues. Talked to the service guys and they're looking into it as a possible bug for Subaru to fix.
 

·
Registered
Joined
·
169 Posts
I had an aggravating week with the USB port. Almost every time I started the car, it was unable to load the memory stick that holds my music. I'd unplug and replug it, then it would be found and after I hit the play button, it would pick up where it left off on the song that had been playing before. The key word here is "almost". Once or twice during the week, it would find the stick and start playing immediately, usually when the car had been shut off for only a few minutes or less. Saturday, it worked every time, with the exception that I still had to hit the play button for the music to start, although at least once the music started without me having to do that. This morning it worked when I left the house and again when I returned home. However, since I was going to mow the yard this afternoon, I didn't park in my usual spot. After I aborted the mowing (see the off topic forum), I move the car back to its spot, and once again I get the "loading media" message. Now I'm real curious to see how it behaves tomorrow. As annoying as this is, it's better than the lock up DebsXV and others experienced.
 

·
Registered
Joined
·
2,285 Posts
So far I have had zero issues with the head unit over the past 3 days. No freezing, no lag and I have been playing with it a lot. Before I turn the car off I just turn the volume down to zero.
I do have the Nav and will say she has a very nice voice..:wub: My only wish was that the streets were better indicated as to where to make a turn. Hard to explain but, it was better in my previous car. I did run a few comparisons between Waze and the Navi.
Both always calculated the same route, so that was good. My last vehicles Nvai was completely :WTF so I never used it. What is cool is that lets say your using the Nvai and decide to change the screen to the radio, the nav directions get thrown up to the upper screen so you can use it there. No maps, just turn by turn but, it's nice to have that.
 

·
Registered
Joined
·
44 Posts
My HU displayed the "no service/check antenna" message the entire drive home from lunch. I turned the vehicle off for a minute, restarted, and experienced the same issue. The drive home from work was normal.
 

·
Registered
Joined
·
196 Posts
My HU displayed the "no service/check antenna" message the entire drive home from lunch. I turned the vehicle off for a minute, restarted, and experienced the same issue. The drive home from work was normal.
How hot was the ambient temp in the car? I've seen a lot of '17 Impreza owners report most of the issues occur when the unit overheats.
 
1 - 20 of 999 Posts
Top