Subaru Crosstrek and XV Forums banner
1 - 4 of 4 Posts

·
Registered
2018 Lifted 6-speed Crosstrek
Joined
·
2,172 Posts
at first the adapter was working great for me, now not so much.

2018 Premium
Pixel 5 - but running android 12 beta - im wondering if this could be my issue.

After the first couple drives of it working totally fine, it stopped connecting. Tried to re-pair the adapter and my phone as I did the first time but it does not seem to want to pair again. It also removed the phone/headunit BT connection, so I had to readd it to my phone to at least get BT music working again.
 

·
Registered
2018 Lifted 6-speed Crosstrek
Joined
·
2,172 Posts
Android 12 has been in public release since October 2021. Are you running the Android 12L beta? Is your Starlink HU running the latest fireware?

This is the link for the Motorola MA1 adapter support page: Motorola Sound Support

Read through the FAQs to see if it helps. Good luck.
Something similar happened to me a couple times. What I do with the MA1 plugged in and the LED "flashing" green... is to go to the BT settings of the phone and select the BT id of your Head Unit to connect to it. Wait a little while and AA should reestablish a session with the HU. In my case, I believe it happened because at one point I used my wife's phone to test the MA1. Btw, I've been using General Availability (GA) Android 12 and Android Auto 7.4.xxxx betas. I joined the beta program for AA in the Google Play Store. Some of these later AA beta versions have fixes not available in the GA versions. Some of the recent beta releases have addressed issues with text messages notifications.

Edit:
You might also find some help in the Google Android Auto Community

These are some of Android Auto known issues that have been acknowledged by the Android Auto Team as of 02/21/22. I hope that the Spotify music stuttering over BT that I experience when voice navigation goes on is addressed in the next Android 12 Build for the AT&T Samsung Galaxy S21+ mentioned in the Samsung announcement.
My current HE version and Android 12 version
Font Terrestrial plant Darkness Book Event
Plant Gadget Radio Personal luxury car Display device
 

·
Registered
2018 Lifted 6-speed Crosstrek
Joined
·
2,172 Posts
Took the Moto adapter out of the Trek and put it in the truck. Worked perfectly smooth as is with my Pixel 5 and the headunit ive got in the truck.

So it leads me to believe that the issue with the Trek is the shitty OEM headunit (and or software update).
 
1 - 4 of 4 Posts
Top