Subaru XV Crosstrek Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
FYI
Canada spec 2013 limited
3c Temp
day i
Start Car, realize MFD is black.
3 minutes MFD now has some faint horizontal lines
5 minutes MFD now has more lines some vague highlighting of what is normally on screen
15 minutes MFD now has even more lines and some info now sort of legible 25%
25 minutes drive to dealer, info now legible but completely over written by horizontal lines
45 minutes MFD now back to blue colour all info legible, what problem

day ii
7 c Temp
no problem

day iii
just like day i
turning heater/defrost on full has no impact seems to require warm up like old televisions

day iv
just like day 1

Dealer has ordered new MFD.

Anyone else with this situation?
john
 

·
Registered
Joined
·
12 Posts
Hello from Canadian spec 2013 Sport

Interesting that happened in MFD even through it's made in Japan. I was told it would work with rear view camera but mine doesn't have camera's pre-wire in the rear hatch door (I have already disassembled the 4 pieces interior covers). You are lucky to have limited model where has camera wiring harness ready.

Post us know if it has camera plug-in port on rear MFD.
 

·
Registered
Joined
·
2,763 Posts
Depending on the temperature. The connection to the glass display which is usually a rubber strip, is not making full contact with the glass. With extreme swing of temperatures this is causing the rubber strip to expand and con-track. Thus giving you a partial display. I've seen this on electric meters first hand when they first came out in the field. Depending what time of day/temperature some would or wouldn't display readings. In addition it could be possible bad (weak) soider connection, or IC chip . Years ago like in the 50s' it wasn't uncommon to go back to the dealership several times to get all the bugs worked out of a new car. Now in days with so many mechanical and electronic parts. I'm amazed how well everything works without any issues.
 

·
Registered
Joined
·
149 Posts
Can you take a picture of the rear of the MFD? I would like to see what type of connector they have. Thank you in advance!
 

·
Registered
Joined
·
109 Posts
20140505_164245_resized.jpg

The Forester MFD has two plugs, one is an 8 pin, one is a 12 pin. The back up camera input is intergrated into one of these plugs. Haven't had a chance to see if the XV Crosstrek has similar plugs on it's display (US models) that would allow it to be plugged in.
 

·
Registered
Joined
·
149 Posts
I was told that the limited crosstrek model has the wiring to use the high grade mfd. Just want to make sure before I attempt to upgrade .
 

·
Super Moderator
Joined
·
8,379 Posts
Hello from Canadian spec 2013 Sport

Interesting that happened in MFD even through it's made in Japan. I was told it would work with rear view camera but mine doesn't have camera's pre-wire in the rear hatch door (I have already disassembled the 4 pieces interior covers). You are lucky to have limited model where has camera wiring harness ready.

Post us know if it has camera plug-in port on rear MFD.
Have a look at this thread...
http://www.subaruxvforum.com/forum/lighting-electrical/767-backup-camera-multifunction-display.html

Installed mine last year... still works!
 

·
Registered
Joined
·
109 Posts
I was told that the limited crosstrek model has the wiring to use the high grade mfd. Just want to make sure before I attempt to upgrade .
I also have a Limited and can tell you the wiring is not there (had it apart last night attempting to install the Forester cubby LED). Plus you would need the input buttons that mount on the steering wheel, roll connector, etc. Doubt it would be an easy mod.

I find it interesting that the Canadian Limited gets HID's and the Multi-Function display and is only $1,000 more than the US model...
 

·
Registered
Joined
·
109 Posts
It's a small LED that lights up the cubby in front of the shifter. The mount is in the XV for it...but no wiring.
 

·
Registered
Joined
·
138 Posts
the RVC should plug into the 8 pin connector, look for threads here there are few, sorry late to the conversation by about 4 years...... a lot of advice on various threads on which of the 8 pins are needed to run the camera and reverse gear etc.
 
1 - 14 of 14 Posts
Top