Subaru XV Crosstrek Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
there is what i call a somewhat random glitch/clicking sound on audio when playing either radio or music via apple car play.
anyone else have this issue.
i do have an appointment with dealer and their tech service.possible software issue?
 

·
Registered
'19 Crosstrek Premium, 6MT, CWP
Joined
·
9 Posts
I think I've experienced this issue as well, sometimes even a brief light "popping" noise. It hasn't bothered me enough to look into it but since you have an appointment with the dealer, I'd love to know what they find! :happy:
 

·
Registered
Joined
·
135 Posts
Discussion Starter #3
well when i went to pick up my cargo cover and tray liner the dealer tech wiz seems surprised and said he never heard that before. he then said to let the techs know when i bring my car in to have fog lights installed and maybe they can figure it out. that appointment is this coming monday the 29th. it only seems to happen a bit now(maybe the unit is breaking in ) and mainly when using car play with my USB cable and only once or twice,but to be honest i don't spend long amounts of time in the car. i might mention it again if i hear it enough over the weekend. i might see if there is a software update available( i have the base model w/ 6 sp manual) so can't update software my self. will let you know if anything comes of it.
 

·
Prefers non-orange cars
'18 and '19 Crosstrek Limiteds
Joined
·
9,231 Posts
well when i went to pick up my cargo cover and tray liner the dealer tech wiz seems surprised and said he never heard that before. he then said to let the techs know when i bring my car in to have fog lights installed and maybe they can figure it out. that appointment is this coming monday the 29th. it only seems to happen a bit now(maybe the unit is breaking in ) and mainly when using car play with my USB cable and only once or twice,but to be honest i don't spend long amounts of time in the car. i might mention it again if i hear it enough over the weekend. i might see if there is a software update available( i have the base model w/ 6 sp manual) so can't update software my self. will let you know if anything comes of it.
>the dealer tech wiz seems surprised<

No comment... :D

If you have a '19 you should be on the latest software (i.e. firmware) for the infotainment system. Please let us know what happens!
 

·
Registered
Joined
·
135 Posts
Discussion Starter #5
pre appointment update. called dealer to just get a estimated appointment time for installing mudflaps and foglights.
also inquired about updating firmware if needed.service person said she would ask tech wiz if there was a firmware update for my vehicle.after asking she indicated he wasn't sure but to ask when i bring the card in on monday! will keep you up to date on the firmware/software update.
 

·
Registered
Joined
·
5 Posts
I have something similar going on. For me it doesn't matter if I'm playing music or not, the volume can be turned all the way down/muted. It almost sounds like the sound of clicking from a touchscreen keyboard. I haven't brought in my car for it because it only happens occasionally and I doubt it would happen when I bring it in. I have also heard the same sound when I had a loaner 2018 impreza. Let me know if they find anything.
 

·
Registered
Joined
·
86 Posts
Add me to the list of those experiencing this. I’ve noticed it occasionally while driving ... clicking noise and volume level fades in and out (despite no adjustment on my part).

Yesterday while sitting in a parking lot with the radio on, I was able to gather more info when it started again:
- engine off
- affected AM stations only (XM and FM were fine)
- there were no high tension or other wires anywhere near; none in sight
- no obstructions that would affect an AM signal (AM is generally not as affected by those in any case)

I, too, would love to hear any Service Dept feedback.
 

·
Registered
2020 Pearl White Crosstrek Sport with Eyesight, CVT
Joined
·
166 Posts
I had the same issue on my 2018 Crosstrek Sport (Canada), on 1 station on AM radio. As reported in another thread, an update to the Head Unit fixed the problem about 6 months ago. Good luck
 

·
Registered
Joined
·
135 Posts
Discussion Starter #9
Thanks for the feedback.So far no resolution and the “clicking” just seems to be part of the system.The service tech was nice but didn’t have an answer when we sat in the vehicle and he heard it. Still waiting for the fog light install. It seems when i first got the cost from the dealer they didn’t include labor and then the part was not in after i showed up for appointment. have it now rescheduled and with a slight discount on the part. I am going forward with the install. Still dealing with the random “clicking” sound. Helps to know that others have experienced it as well.
 

·
Registered
Joined
·
3 Posts
+1 2019 Premium. It's really annoying me and is most noticeable on AM talk radio. It's difficult to duplicate too. If I'm just sitting in it not driving around it doesn't seem to happen as much, but when I'm driving around it's really bad.

Forgot to mention on a whim I stopped into Car Toys and talked with one of their Techs. He thought I was crazy.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #14
i have not noticed the clicking in a while and there have been a few iPhone updates so who knows
 

·
Prefers non-orange cars
'18 and '19 Crosstrek Limiteds
Joined
·
9,231 Posts
There's also a TSB about this with the HK amp but @Forx has a Premium.
 

·
Registered
Joined
·
3 Posts
My phones a Pixel 3 .Still unsuccessful in verifying the firmware. Tried both the Ah app and the was looking for the wifi updates in my settings but couldn't find it. Since I was there I tried some different settings. If I turn the HD radio button on, the popping is gone BUT rather than pop it's replace with with audio almost disappearing where the popping was. They'll be talking away and it just drops to almost a muffled mumble.
 

·
Registered
2019 Base MT
Joined
·
12 Posts
Same with my Pixel 3 and '19 Base, but randomly. It will be fine for weeks at a time, then do it for a day or two before going away again. I usually only listen through Android Auto, but confirmed it's there on radio too. I assumed it was due to the amp and speakers I installed, but now I'm not so sure.
 

·
Registered
Joined
·
32 Posts
This may be caused by a rouge app on your phone, I had insane clicking on my personal phone untill I tried my work phone, (1 is rooted android, other stock). Easiest way I can tell you is try a different usb cable and try flushing the cache partition in your recovery mode. (Warning: Do NOT wipe any other partition apart from cache otherwise say bye to your data). For me it was one of the subaru apps that seemed to conflict with android auto.

I'd try those things first, if your on iphone I cant help you but android I can if you need it.
 
1 - 19 of 19 Posts
Top