Subaru XV Crosstrek Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone, I've been running into an issue where after about an hour of driving my dash lights up like a Christmas tree. a/t temp, all eyesight lights, abs, traction control but no check engine. I assumed it was because of the brake light switch so I got that replaced and a few days later it happened again. Has anyone experienced similar problems, some said that it might be due to a bad seal on my gas cap but it seems like its on tight. My main concern is the a/t temp light as I'm very close to 100k where my drivetrain warranty expires.
 

·
Registered
Joined
·
4 Posts
Did you mention this issue to the dealer when you had the brake switch replaced? The AT temp warning light could be very serious. Your next trip should be to get it diagnosed. Continously driving isn't in your best finacial interest. For the future, a "loose" gas cap will only trigger the CEL - not the Christmas tree you are currently experiencing. Please post the result of your diagnosis for future reference.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Did you mention this issue to the dealer when you had the brake switch replaced? The AT temp warning light could be very serious. Your next trip should be to get it diagnosed. Continously driving isn't in your best finacial interest. For the future, a "loose" gas cap will only trigger the CEL - not the Christmas tree you are currently experiencing. Please post the result of your diagnosis for future reference.
Turns out it was a short caused by corrosion in my trailer harness, all fixed now
 
1 - 3 of 3 Posts
Top