Subaru Crosstrek and XV Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
First off hello to all. I am new to this forum. Own a crosstrek hybrid touring. 2014 bought brand new back then. Only visit back to Subaru was a 30000 mile check up. Seen what they did and haven't been back since. Pretty mechanicly inclined until it came to these stubborn wheel bearing assemblies. I heard the decoder from the wheel sensor only mates up with Oem parts. So I bought one through GMB. Mechanic just called after new wheel sensor, back plate and wheel bearing assembly was installed with error codes erased was told mechanicly sound but error codes came back on. Ok guys and gals mechanic also said we might have to replace a rear wheel bearing also. With that said would another wheel bearing going out knock the sensor out of whack. He told me we'll figure it out by running the diagnostics. Find out tomorrow for sure but just putting it out here on this great forum. Very informative. See what you good folks think might be the reason for a new sensor not to work. Abs, a/t temp and hill assist with check engine light I guess are all monitored by these wheel sensors. Any imput is appreciated.
 

·
Registered
Joined
·
458 Posts
I'm sorry but it is confusing what you had done, what you are asking. You say the sensor, back plate, and wheel bearing were changed yet now say the wheel bearing needs changed??? What was the initial problem and who is GMB? If you changed a rear bearing assembly, backplate replacement is recommended per the TSB but the sensor? Why was it changed? I can tell you that if you used a non Subaru wheel bearing assembly, there is a good chance you'll have issues with the sensor working correctly. Only OEM is recommended.
 
1 - 2 of 2 Posts
Top