Subaru Crosstrek and XV Forums banner

Carplay Smartphone Connection Error

4777 Views 20 Replies 16 Participants Last post by  iamnotcreative
I have a 2022 Crosstrek Limited, updated the HU firmware to Rel_UG.22.13.70 recently and Carplay stops working with "Smartphone Connection Error" - Please unplug, wait a moment and re-plug your device...
No problem connecting my iPhone 13 with iOS 16.1 to two other rental cars, so the problem is with the Crosstrek HU. I tried forgetting the vehicle in the phone's Carplay setting, reboot the phone but none works. Also the phone is charging when plugged in, but somehow couldn't connect to the HU. Should I try to reboot the HU? Or reset the HU back to the factory setting? Thanks.
21 - 21 of 21 Posts
Since this thread is actually active I thought I'd chime in that my 2019 Legacy has the exact same issue. I've tried tons of different cables; most of the time I get the "Smartphone connection error" screen when I first plug in, and then if I unplugged and replug it works about 75% of the time. It will also randomly disconnect when driving which is fun. This is with the latest firmware available OTA. Hopefully someone finds a solution eventually although I feel at this point it must be the firmware in the head unit.
21 - 21 of 21 Posts