Subaru Crosstrek and XV Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
So I have a 21 Limited with the 8.4” screen and I have a popsocket on my phone and a vent clip for it. Any time I pick the phone up or hit a hard bump and the phone moves, the CarPlay functionality will stop. I’m not sure if this is a Subaru or CarPlay problem, but it’s obnoxious because if I’m driving with navigation and it happens, the CarPlay will take about 10 to come back and the navigation stops and I have to go back and start the nav.

I did replace the stock apple lightning cable with a better anker cable but the problem persists.

Any suggestions?
 

·
Registered
Joined
·
147 Posts
I’ve experienced nearly the same thing, a couple of times. I have to wonder whether the lightning contact points inside your phone might be dirty... one, on one side is all it takes.
I presume you tried flipping the lightning connector around, to see whether that had any positive effect?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
I’ve experienced nearly the same thing, a couple of times. I have to wonder whether the lightning contact points inside your phone might be dirty... one, on one side is all it takes.
I presume you tried flipping the lightning connector around, to see whether that had any positive effect?
I've cleaned the cable and port and it's still happening. Same thing happens if you pick the phone up too quickly or something. It's so frustrating and if I can know if it's CarPlay or the Subaru, then I can at least know where to start.
 

·
Administrator
2021 Crosstrek Limited, Pure Red
Joined
·
5,448 Posts
If the connection skips when you move the phone, the issue pretty much has to be with the phone (most likely) or the cable. There’s almost zero likelihood it could be the Subaru.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
If the connection skips when you move the phone, the issue pretty much has to be with the phone (most likely) or the cable. There’s almost zero likelihood it could be the Subaru.
That's what I figured, but I have tried replicating it in my Jeep and it doesn't happen. So not sure if it's the Subaru USB port or the software.
 

·
Registered
Joined
·
29 Posts
Is anyone able to plug their phone in and use carplay for GPS and also able to plug in seperate ipod and use for music? Im not able to and wasnt sure if this was normal. One cancels out the other in my car.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 ·
Is anyone able to plug their phone in and use carplay for GPS and also able to plug in seperate ipod and use for music? Im not able to and wasnt sure if this was normal. One cancels out the other in my car.
Not sure but I sometimes use CarPlay for GPS and then listen to SiriusXM, so I'm sure if you made one of them bluetooth then it'd work.
 

·
Registered
21' Premuim manual Ice Silver Metallic
Joined
·
50 Posts
it might be worth cleaning out the connector port on your phone with a tiny pick or something. when my phone has issues similar to this I end up digging out a ton of debris and lint from inside my phone.
 

·
Registered
‘23 Crosstrek Premium
Joined
·
32 Posts
even Mazda CX50 has "wireless carplay/android auto" capability - step up Subaru!
:oops:
 
1 - 14 of 14 Posts
Top