Subaru XV Crosstrek Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1 (Edited)
I have a 2019 Crosstrek Limited with Eyesight. In the past week or so I have randomly gotten a "Access Key Not Detected" warning and I could not lock or unlock my car using either one of my key FOBS.
I can lock the vehicle with the key and the alarm and everything works. I can get in the car an start it so the battery in the FOB are OK.
I cannot predict when it will work o not and the dealer said they have never head of this before. I told the dealer to google "access key not detected" and they will get several hundred thousand hits and they did...seemingly to their surprise. They said no one ever complained to them.
Anyway, it is a issue with me and a problem particularly for my Wife. Has anyone had this occur? How have you resolved it? What was the problem?
TIA

EDIT, nothing works on the FOB's, lock, unlock, rear hatch opens, emergency but the little red LED that indicates signal being sent flashes when button is pushed.

it did not work last night but it works this morning?
 

·
Registered
'19 Limited
Joined
·
42 Posts
Not directly Subaru related but similar issue on a '17 Honda Ridgline. Loss of recognision of the key fobs, lights comming on ate odd hours while parked and random alarm activations. It took about three trips to the dealer to have it happen at the dealer. Replaced the access module as a solution.

I would be at least talking to the the dealer.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Not directly Subaru related but similar issue on a '17 Honda Ridgline. Loss of recognision of the key fobs, lights comming on ate odd hours while parked and random alarm activations. It took about three trips to the dealer to have it happen at the dealer. Replaced the access module as a solution.

I would be at least talking to the the dealer.
I have talked to the dealer, as I said.
I have also searched the internet and while the problem is there, a solution is not.
 

·
Registered
2018 Crosstrek Sport 6 MT
Joined
·
3,340 Posts
Welcome Pete

Next contact SHOULD BE SOC Subaru of Canada....

Give them your Vin # details of your concern, tell them you have had it at the Dealership level and what was said, Politely suggest this Needs to Go Higher up the Chain.... " We have Never Heard of This " Must be standard answer they are teaching the Service staff at Updated training modules.....?? :sFun_whistle:

Keep Pressing

The Answer is Out there :wink:

 

·
Registered
Joined
·
323 Posts
Might be helpful to use your phone and record pushing the unlock on the remote while also showing (thru the window) that the doors are still locked. A video can do wonders for proof of the problem. Or record hitting the emergency button with nothing happening.
 

·
Registered
Joined
·
79 Posts
I had this issue also. It mainly happens during the winter and rarely occurs in the summer. By chance, did you replace your interior lights with LED bulbs? Or are you completely stock? FYI, replacing the batteries in the FOBS doesn't help... haha.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
I had this issue also. It mainly happens during the winter and rarely occurs in the summer. By chance, did you replace your interior lights with LED bulbs? Or are you completely stock? FYI, replacing the batteries in the FOBS doesn't help... haha.
This is happening in end of May.
I have not changed anything.
The car is only 3 months old. I have a garage door opener on on my key FOB but, the issue happens with my Wife too and has no other items on her FOB.
Checked online and it seems ot be a common problem but none of the posts online has a solution. What did you do?
 

·
Registered
Joined
·
79 Posts
This is happening in end of May.
I have not changed anything.
The car is only 3 months old. I have a garage door opener on on my key FOB but, the issue happens with my Wife too and has no other items on her FOB.
Checked online and it seems ot be a common problem but none of the posts online has a solution. What did you do?
The only thing I did was switch my trunk LED back to stock. I know when it doesn't detect my FOB, I can still lock the car if I put my FOB right up against the front windshield.

Sent from my MI 8 using Tapatalk
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
UPDATE:
Got an appointment with the Dealer yesterday. I did take a video of it not working and even the key not working. It actually did not work while at the dealer and they saw it for themselves. They changed the battery in the FOB's. It works...for now.
They had no explanation. They had not idea why the emergency key did not work as it is not connected to the FOB function..

I think it may come back but, will have to wait and see.


I also told them about the presets disappearing on the radio and they said this has happened before but they also do not know why.
 

·
Registered
Joined
·
323 Posts
I also told them about the presets disappearing on the radio and they said this has happened before but they also do not know why.
Did they update your firmware version which will fix that? Of course, there are still issues with the latest firmware in that sometimes the sound no longer works on the AM/FM stations until the car is shut off and restarted.
 

·
Registered
Joined
·
4 Posts
Might be helpful to use your phone and record pushing the unlock on the remote while also showing (thru the window) that the doors are still locked. A video can do wonders for proof of the problem. Or record hitting the emergency button with nothing happening.
Great advice 05Moose. I had a recurrent rattle in the overhead eyesight console on my '18 XV and had taken it to the dealer twice, without a fix - the dealer couldn't replicate the issue. I took a video (with sound) to show the type of road I was travelling on and the accompanying noisy squeak/rattle. The dealer took down the console and saw that there was a problem with a loose cable connector. Problem solved! It was doing my head in and the video proved there was a problem.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #12
UPDATE #2

Well, that didn't work. Couldn't lock my car all weekend. FOB (both, my Wife's doesn't work either). Thing is (and yes, i looked at the manual), to lock the car, all 4 doors, you have to click lock from the inside, close the door and then re-lock the drivers door from the outside. Problem with this is that if you open the door with the key, the alarm goes off and you have to start the car to stop the alarm.
So, back o the dealer tomorrow.

As for the radio presets disappearing, yes, it seems OK for now.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #13
Update #3

Well, got a new (just one) key FOB. They said only one FOB and if that fixes it, then they will order another.
So, the new FOB worked for a week, then failed to lock the doors again. The old FOB did not work either. (took video to prove the faults)

Went back to the dealer and showed them the video and they took the car in the shop. This time they said the start button module antenna had corrosion on the connectors and they cleaned them (?). This should fix the problem, they said. Not sure how the start button module interacts with the lock function of the FOB but, that is all they are going to do....this time.
So, we will see how this works.

The saga continues
 
1 - 13 of 13 Posts
Top