Subaru XV Crosstrek Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have no sound coming from the radio when in the FM or AM mode. SXM has sound. Call dealer ship they are puzzle? HAs any one had this happen?
 

·
Registered
'18 and '19 Crosstrek Limiteds
Joined
·
7,026 Posts

·
Registered
2020 Crosstrek Premium; 2010 LGT stage 2+
Joined
·
46 Posts
I had that happen the other day. On my lunch break, when I was going to swing by the dealer, it worked again. No issues since. My bluetooth worked fine.
 

·
Registered
Joined
·
12 Posts
Just had this issue happen to me tonight - 19 premium with a 19 limited non-nav head unit. No audio from FM/AM but station identification and song info was displaying. Android Auto and SXM working fine. Restarting car multiple times, turning HU off and on did not resolve. Pulling the battery cable for a minute resolved it. Checked for update again (just updated last week) no update available.

Good to know it resolved itself without pulling the battery. Next time I'll just wait it out. Don't really want to try to get dealer service on it since I'm sure the swapped headunit falls outside of the warranty. Hopefully a future update resolves it.
 

·
Registered
Joined
·
12 Posts
Just had this issue happen to me tonight - 19 premium with a 19 limited non-nav head unit. No audio from FM/AM but station identification and song info was displaying. Android Auto and SXM working fine. Restarting car multiple times, turning HU off and on did not resolve. Pulling the battery cable for a minute resolved it. Checked for update again (just updated last week) no update available.

Good to know it resolved itself without pulling the battery. Next time I'll just wait it out. Don't really want to try to get dealer service on it since I'm sure the swapped headunit falls outside of the warranty. Hopefully a future update resolves it.
I should note that the version I have currently is 19.22.70
 
1 - 5 of 5 Posts
Top